Using Purple Pen for Course Planning

Collated by Ken Thompson based in part on programme help screens. Updated 23™ Jan 2024

Please email comments & suggestions to me at cartography@ihug.com.au Note: Generally speaking it is
easiest to work through the programme referring to the help screens as necessary. These notes are based on
version 3.5.1 It is strongly recommended that users update to this version. Updates to the software can be
obtained from http://purple-pen.org

New topics/edited areas are highlighted in yellow within the document

e Comparison between Purple Pen and OCAD removed

e Installing programme section re-written. p2
e Updating p3
e New feature: Event/Move all controls. Allows moving all the controls (and other course features) to

handle offsets, rotations, or scaling of the underlying map file. p10

e New description symbols from the IOF Control Descriptions Standard 2024. Adds Railway and Map Flip.
Because the 2024 standard is the same as the 2018 except the two new symbols, the 2024 standard is merged
with the 2018 standard when selecting which control standard to use. p5

e Correctly handles embedded layout images in OCAD files.p4
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Installing the Programme

Note: The programme will only run normally on a PC system.

If you have an Apple computer you will need to run Parallels or similar and install Windows. Update note
for Apple/Linux users: Peter Golde, the author of Purple Pen has written an article on how to set up an
Apple or Linux computer using Virtual Box at no cost: http://purple-pen.org/virtualbox.htm

PC Installion:

1. The programme can be obtained from: http://purple-pen.org

2. The installer will put the programme in the standard programme directory: c:\Program
Files(x86)\Purple Pen. The programme will still work fine if all files are copied to another location
on your PC or even on a USB stick or portable hard drive. However the files should still be in a
folder called Purple Pen

3. The programme defaults to English (United Kingdom). To change it to English (Australia) go to
Event-> Customize Description Text and select English (Australia) and tick Make this the default
language for new events and click OK. It is no longer necessary to use the modified symbol.xml file
to achieve this
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Choose the language used for textual control descriptions:
English [Australia) e

Make this the default language for new events

Table of differences between UK and Australian symbols is as follows.

English ( United Kingdom) English(Australia)
Ditch Minor watercourse
Re-entrant Gully

Stream Watercourse/river
Hedge Linear thicket

If you prefer to have your Purple Pen folder in a different location copy all files to that location.

Updating the Programme

1. From time to time when you load Purple Pen you will say an update is available.

2. Ifyou click Yes to install. As above the new version will install in c:\\Program Files(x86)\Purple Pen

3. Copy all the files from c:\Program Files(x86)\Purple Pen to your own Purple Pen directory if itisin a
different location

Creating a new event

When you first start Purple Pen, you have the choice of opening an existing event or creating a new one. If
you want to just see how the program works, you can open an existing event and open the sample event that
comes with Purple Pen.

However, once you have finished playing with the sample event, it is time to create your own event. Select
"Create a New Event..." from the initial dialog and you will be asked a series of questions to gather the
information for creating a new event.

Event Title

First, enter the event title. This should be a short, one line description of the event. It will appear as the first
line on each control description sheet. It is also used as the file name for the event file. Once the event title is
entered, click "Next".

Map File

Your event must use an OCAD map file, or a bitmap map file. All versions of OCAD are supported; for a
bitmap, you can use TIFF, JPEG, GIF, PNG, or BMP formats. PDF files are also fine. The biggest
advantage of using a georeferenced OCAD file is that when you re-generate a background map previously
marked controls remain in the correct position on the map. With other file types position adjustments may be
necessary. If you use anything other than an OCAD file Purple Pen needs to know the map scale. This
indicates how distances on the map related the real world, and it needed to calculate the lengths of courses.
Generally this is shown on the map..
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Previously there was an issue when using a OCAD 2018 file using the new OCAD feature which allows
graphics (eg logos etc) to be embedded in the OCAD file. Correctly handles embedded layout images in
OCAD files.

If you wish to add any additional graphics images to the Purple Pen project simply go to Add -> Image

If sing a PDF of the map as a background in Purple Pen make sure the pdf has been generated by OCAD
which produces a vector pdf file

Click the "Choose map file..." button and select the map file you will use. Purple Pen will immediately try to
read the map file to make sure it is usable (if it isn't, an error message will appear). After you have chosen
the map file successfully, click "Next".

The map file is used every time Purple Pen loads the event. If you send the Purple Pen file to someone else,
they must have a copy of the map file and any linked graphics files also to successfully load the event and
view the map.

Changing the Map File

If you wish to change the background map go to Event -> Map File and click Choose map file.

Map Resolution and Scale

If you use an OCAD map, Purple Pen automatically reads the scale from the map, and this step is skipped.

If you use a bitmap (JPEG, TIFF, etc.) or pdf file as your map, Purple Pen needs to know the resolution and
the map scale in order to correctly calculate the lengths of courses, the sizes of controls circles, and so forth.
Purple Pen attempts to read the bitmap resolution from the bitmap file, so this may already be set correctly,
but you should check the value to be sure. The resolution is expressed in dots per inch -- the number of
pixels in each inch of the printed map. The map scale indicates how the map relates in size to the real world.
After typing in the bitmap resolution and scale, click "Next".

Print Scale

Next, chose the scale at which you wish to print your competition maps. Most of the time, this will be the
same as the scale of the map, so unless you know want to print at a different scale, just click Next. (Note:
when creating a new course, you will have the option to change the print scale, so you can have different
scales for different courses.)

Paper Size

Next, chose the size of paper and orientation that you will use to print the map. Purple Pen will attempt to
automatically chose a paper size that fits your map, but you should review this choice and change it if
necessary. (Note: you can change this setting later, or even use different paper sizes for different courses, by
using the File/Set Print Area command.) . So that you don’t cut off part of the map it is important to set the
print margins according to the printer being used to produce the final map. If printing with Snap Hilton
(South Australia) this needs to be a minimum of 5.0mm. If printing elsewhere you should check their
settings before setting up the map. Obviously the person setting up the map for your event needs to be aware
of this issue.
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Event File Location

Next, choose the folder where the file that stores your event will be stored. Purple Pen events are stored in a
file with the file extension ".ppen”. The name of the file will be the event title you chose previously.

You can chose to place the Purple Pen file in the same folder as the map file. Alternatively, you can
explicitly select any folder on your computer.

Control Numbering
Purple Pen automatically numbers all newly created controls. Choose the starting control code you would

like to use. It is very easy to change control codes afterward, so don't worry about this setting if you don't
know what the codes will be for your event.

Create Event
You've answered all the questions needed to create a new event. If you are happy with what you selected,

click "Finish" and you can begin designing courses. If you want to change any responses, click "Back" to go
back to any previous questions.

Manipulating the View
This is basically intuitive:
e Right click allows you to move the map on the screen

e Scroll zooms in & out.
e Go to View on menu & a number of factors can be altered including map intensity & map quality.

Selecting the Correct Control Description Standard

New description symbols from the IOF Control Descriptions Standard 2024. Adds Railway and Map Flip. Because the
2024 standard is the same as the 2018 except the two new symbols, the 2024 standard is merged with the 2018
standard when selecting which control standard to use. To set the appropriate standards for your event go to

Event -> IOF Standards

Adding courses

After the event is created, the Purple Pen main window appears, with the map displayed. At this point, it's
usually best to begin by creating the set of courses that your event will use. You can always add or remove
courses later, if you need to, but it helps to have the initial set of courses created.
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Please note Orienteering SA users: To ensure courses can be easily imported into Sport Software number
as Coursel, Course 2, Course 3 etc. so that they match the Sport Software templates.

Use the Course/Add Course command once for each course that you need, and enter the name of the course.
You don't need to worry about the other fields in the Add Course dialog now. Once you've added all the
courses, they will appear in tabs across the tab of the window in the course tabs. Click on a tab to display
and work on that course.

Initial course design

After creating the courses, it is often a good idea to try out some rough plans for each of the courses. Pick a
course to design first, and click on the tab for that course to view it. Since you haven't designed anything yet,
you will just see the map. First, place the start triangle by clicking the Add Start button on the toolbar, then
clicking on the map where you want the start. Similarly, click the Add Finish button and click to place the
finish.

Next, use the Add Control button on the toolbar (or press Ctrl+A) to place each control. When placing a
control, note that it will go immediately after the currently selected control, or in between the currently
selected leg. As you place controls, Purple Pen will automatically assign control codes and they will show
up in the description sheet pane on the left side. As you initially design courses, it is easiest to not worry
about control descriptions or control codes until later. If you need to, zoom in and out or move around the
map to see the map and control placements more carefully. Note that Purple Pen automatically calculates the
length of the course as you add controls; keep an eye on this to get your course around the right length.

Once you are more or less happy with the first course, move on the next by selecting a new tab. As you
design the second course, you will note a few small differences. Firstly, the start and finish are automatically
placed for you. You can add additional starts and finishes if you want, but in most cases you will want to use
a single start and finish for all courses. Secondly, when you add a course, all the existing controls in the
event show up in light purple. If you want to use an existing control, you can just click on it. In this way it is
easy to share controls between courses.

Refining the course designs

After you finish the initial design of the courses, you will want to spend time refining the design until the
courses are exactly the way you want them. Usually there will be an initial refinement, following by field
work checking the control locations, followed by additional refinement after the field work. Several features
of Purple Pen can make this process efficient.

e Asyou move or delete controls, all courses that share that control are immediate updated. You can easily
see the effect of any change, or undo it if it is not to your liking.

e You can quickly see the set of all controls in the event by clicking on the All Controls tab. This allows you to
see if you have too many controls, and easily identify places where controls could be shared between
courses. You can also print an all controls map for field work.

e While designing a course, you can view all the other controls in the event by using View/All Controls. This
allows you to easily identify places where controls could be shared between courses.

e The Control and Leg Load report allows you to check if some controls or legs have too many competitors.

e Once your have finalized control locations, you can see entire the description for each control by simply
clicking in the appropriate box in the control description pane.

e With the Text descriptions it is generally it is recommended that you stick to the standard ones. If you have
installed the Australian version of symbol.xml this should meet your needs. If you do want to change
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anything for the current event go to Event -> Customize Description Text. Any changes you make will only
apply to this event

Final polish

Once you are happy with all of the course designs, and all the control locations have been field checked, you
can use Purple Pen to polish off the final details before printing. Here are some things you may wish to do:

o To choose the type of finish (eg taped route to finish) right click on last control on control list on left
of screen and select the type of finish.

o To make a marked route (referred to as flagging in PP) first select leg then under Item -> Leg
Flagging can be selected. With partial flagging the point can be dragged to correct position. This
option will only appear if you have selected a leg.

e Using the All Controls view, make sure that every control has a good description. Remove any
controls that are not used by any course. Do a final check for controls that are too close together.

« Update the control codes to match your control inventory, using the Change Codes or Automatic
Numbering commands.

o Calculate the climb for each course and enter it by clicking in the climb box in the control
description pane (or use the Course/Properties command).

« If some courses are printed at a different scale, set that with the Course/Properties command.

o Add gaps to control circles and legs to avoid obscuring important map features. Select object and use
Add Gap Button ---- or click CTRL G. Click once on part of circle or click and drag on segment of
line you wish to delete. To undo cut line select and drag one of the end points. If you wish to adjust
the size of the gap select the circle or line and drag (left mouse -> hold and drag) one or both of the
blue handles

o Move the control numbers to places that don't obscure important map features.

« If you are using pin punching, double check that each control has the correct punch pattern using the
Punch Patterns command.

« Place any necessary special items, such as forbidden areas, water locations, or forbidden routes.

o Place the control descriptions onto each course in a place where it doesn't overlay important
information.

o Set the print area if you don't want to print the entire map.

e Run the Event Audit report to discover any potential problems or missing items in the event.
Reports-> Event Audit There are other reports in this section you will find useful.

« Add any special text you want to place on map using Add Special Item -> Text There are a number
of options in this section.

o A new feature (Ver 2.2.4 onwards) is to be able to add a white border around the control numbers.
This helps to improve clarity particularly where there are large dark areas such as buildings. To do
this go to event - > customize course appearance and you will see there is an option to have a white
outline around the numbers. The size can be altered. I suggest you try 0.20mm as a starting point.

o Changing Event Title Left click into present event title until it turns yellow. Click into yellow and
change. Use a | if you want to break it into two lines. This effects all courses.

Fl

Mack Creek OY
11th April 2022

All controls 47 controls
~ | | | | | |

All of the above commands are described in the help screens.
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Printing

Before arranging to print courses make sure colours for purple on original map have been set correctly.
Currently to get best results set to C35, M85, YO0, KO. This is now the current (2019) IOF standard

Beware of maps that have multiple colours on table. Purple Pen will pick the lowest one on the table and
defaults to whatever colour is recorded in the background map. A safer option is to set the colour purple
in Purple Pen. Event > Customize appearance Then set as below:

Purple Color
Blend purple with underying map colors
Uze purple color from map
Cyan: 350 = Magenta: 850 =

Yellow: D0 Black: Do =

Once your courses are completely done, you will want to prepare files to send or take to the printer.
Produce a pdf file for each course: Go to File -> Create Pdfs. If it is an A3 map make sure you change to
A3. Then tick the courses you want. | suggest you leave it at one per course as you will want different
numbers printed for each course and the combined file may be too big to email.

You can print out the control descriptions for each course using the Print Descriptions command.

If you are using pin punching, print out master punch cards for use in control card checking using the Print
Punch Cards command.

Finally, you may wish to print out a Course Summary and Control Cross-reference report for reference
during the event

Overview of Variations

Starting with version 3.0, Purple Pen supports courses with Variations.

Variations are often used in relay courses, so that teams can race head-to-head with a mass start, but reduces
the ability of competitors to follow each other. Different team members run different variations, but as a
whole each team runs the exactly same set of legs. Variations (especially loop variations) can also be used in
single-person races.

The simplest form of variation is a fork. The following diagram shows the simplest possible fork, with two
variations:

v
31
There are two possible ways through the course: A and B. Variation A visits controls 31,
48 40 48, 36, 38. Variation B visits controls 31, 40, 43, 38. In a two-person relay, one team can
3|6 4|3 run variation A, then B, while another team runs variation B, then A.

H_)

38
Q
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A more complex course can sequence two or more forks. This provides more possible ways throught the
course. For example, consider the following course, with two forks:

s 43 There are four possible ways throught the course, which are designated by letter pairs of which
- branches to take. Variation AC visits 31, 48, 36, 38, 50, 39. Variation AD visits 31, 48, 36, 38,
erH 49, 39. Variation BC visits 31, 40, 43, 38, 50, 39. Variation BC visits 31, 40, 43, 38, 49, 39.

opposite branches (e.g., the first leg runs BC, and the second leg runs AD). Each team runs

- In a two person relay, the first leg can run any of the four variations, and the second leg runs the
39
|
© branches A, B, C, and D exactly once.

More complex courses can be set up, included 3-way, 4-way, 5-way, etc. forks. It is even possible to put a
fork within a branch of another fork.

The other basic kind of variation is a loop.

In a loop, the competitor returns back to one of the controls multiple times, making several loops. A
competitor can run the loops in any order. Here is an example of a 3-way loop:

T
31

4|6 4|0 5|2

3|3 32 4|3

32 42

There are 6 possible orders to run this course in: ABC, ACB, BAC, BCA, CAB,

35 CBA. For example, Variation CAB runs the controls in the order: 31, 52, 43, 42,
3'6 31, 46, 33, 32, 31, 40, 32, 31, 35, 36. No matter which order the loops are run, the
(cID course is completely fair.

Creating and Editing Variations in Purple Pen

To create a course with variations, first insert the start and finish, and any fixed controls that should be on all
variations. Then click on the control where the fork or loop should start, and click "Add Variation™ from the
toolbar.

Once you create a fork or loop, the left hand pane will switch to displaying the Course Ordering. You can
use this to select different branches and insert controls on them.

When working with a course that uses variations, you can switch between variations using the gray bar
directly above the map:

Using this, you can display any variation of the course, or "All Variations", which displays all variations
together.

9|Page


mk:@MSITStore:C:/PURPLE~1/PURPLE~1.CHM::/ControlOrderingPane.htm

When printing (or exporting the courses to PDFs or OCAD files), you can select which variations that you
wish to print.Select the course, with variations, then click the "Variations" button to select which variations
to print.

Assigning Variations to Relay Teams

If you are holding a relay, you will wish to assign variations to team members so that every team runs the
exact same legs, and to vary the assignments to minimized the possibility of following. Purple Pen can help
by assigning course variations to teams in a fair, randomized manner. Simply choose the Course/Relay
Team Variations command, and choose the number of teams and the number of legs on each team. Click
"Assign Variations", and Purple Pen will pick a fair distribution of variations.

Exporting Courses to Sport Software

e Go to File > Create E Punch Interchange file
e This will generate an XML file

Open Sport Software and go to Courses > Import Courses and use the following options:
e Courses: Update Existing Only
e Controls: Clear and create again

e File format: XML

Special Note: If for some reason you have set up two or more separate Purple Pen files for an event one of
these needs to include all the courses and controls so that all courses & controls are in the one xml file.

Moving All Controls

A new feature introduced in version 3.5.1 is the ability to move all controls. Go to Event -> Move all controls.
Allows moving all the controls (and other course features) to handle offsets, rotations, or scaling of the underlying
map file.
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Appendix A : Using Purple Pen for Larger Events — Some Tips

By Robin Uppill

Many course planners use the free Purple Pen software as they do not have access to OCAD for course planning.
Purple Pen has many powerful features and is easy to learn for small events, but has features that mean it is useful
for larger events as well.

When planning for events with many courses, the following can be done with Purple Pen:

- Use more than one Event Map e.g. an A3 map and an A4 map
- Produce courses at different scales
- Have Special Items appear on some courses only

Using Multiple Map Files

If you need to use an A3 map for some courses and an A4 map for others, create all the courses using the larger map
first so this can be used as a check, and as the All Controls map. However to ensure when you swap the Event Map
file (see the Event>Map File menu) to the smaller map all the controls are in the correct place on both maps, you
probably need to have your map files as OCAD georeferenced files. So you will need to arrange for whoever
manages the relevant OCAD files to create the required base maps to use for the event.

In Purple Pen, only one Event Map File can be used at a time, having multiple background Map Files and turning
them on and off is not a current feature. So when creating the Purple Pen files for an event where both A3 and A4
Course maps are to be produced, choose the Event Map file as the larger A3 map, then change the Event Map file to
the A4 map to check it suits the shorter courses. For each course you will need to set the print area and paper size
to fit the appropriate Event Map file. By changing the Event Map as required file, you only have one Purple Pen
course file, and so errors in control placement and numbers are less likely than if you use different Purple Pen files
for the different maps, and try to keep track of any changes to make in the different Purple Pen files. PDF files for
printing can be created using the appropriate Event Map File and print area for the course.

Varying Course Print Scale

Each course has a Print scale set in the Course Properties, so printing some courses

Lourse Properties

at different scales is possible, again you need to set the print area and paper size to

Course name:

Cousetype.  Nommal Course = suit each course according the course scale and the size of the map to be printed.

Climb: meters

Length: Automatic km

Class list / Secondary title

The following (optional) text will appear on the second line
of the control description sheet:

Appearance

Map printing scale: 1: (10000 ~

Description appearance:  Text ~
Control circle labels: Sequence number (3) ~

First control number: 1

OK I Cancel



Choose the courses that this object will be

displayed on:
[ All controls
M1 Hard
. - M2 Hard
Using Special Items S
14 Hard
: Purple Pen allows a number of special [15 Moderate Trail
? Add Special ltem ~ . 16 Moderate
items to be added to the courses. []7Eas
I Timed Start . Sreid
M ki Ciosig po Many of these e.g. Text, Optional [J8 Very Easy
W oprional Ciassing Point Crossing Points, Water Locations, will All None
%%  Out Of Bounds Area appear by default on all courses.
f]  Water Location However if you only want a Special Cancel
&= First Aid Location Items to appear on some courses only,
orbidden Route Marking select the Item and then under the Item menu, use ange Displayed Courses” to
X Forbidden Route Marki lect the It d th der the It “Ch Displayed C t
/  Uncrossable Boundary select which courses you want the Special Item to appear on.
-+ Registration Mark
: itionally when adding Text as a Special Item, some special Text Items are also
e Addit lly wh dding Text Special It pecial Text It |
Ab Text available e.g. Event Name, Course Name, Print Scale, some of these by default are
@ Image Course specific values.
~ Line . - . . -
L [ Another useful feature is the ability to add a Text Line in the control descriptions
ectangle . . .
O Hipse when you need to convey extra information to the competitors. Consult the Purple

Pen Help on ”Add Text Line” for this feature. And also consult the Purple Pen Help
for more detail on adding Special Items as referred to above.
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